Retrouver un label local apres packing ?

Questions et discussions autour de la programmation du HP-41.
fjhdavid
Sous apprenti
Messages : 6
Inscription : mer. 24 déc. 2008 13:35

Retrouver un label local apres packing ?

Messagepar fjhdavid » lun. 17 nov. 2014 14:37

Bonjour,

j'ai fait un petit programme qu'avec des labels locaux; puis par mégarde j'ai fait un GTO.. et du coup packing....

Maintenant il m'est impossible de retrouver mon programme; je vois que le nb de registres n'a pas bougé, preuve que le programme est toujours en mémoire.

Comment faire? le GTO . et label alpha ne marche pas, de meme que le GTO. et numero de ligne non plus.

En mode "user" l'appuie sur les touches de la première rangée ne me lance pas non plus les labels locaux correspondants vu qui'ils ne sont plus dans la mémoire visible.

merci pour votre aide,

François

Avatar de l’utilisateur
hpmaniac
Expert
Messages : 205
Inscription : mar. 16 sept. 2008 15:18
Localisation : Grenoble

Re: Retrouver un label local apres packing ?

Messagepar hpmaniac » lun. 17 nov. 2014 20:33

Bonsoir, il faut se positionner avec le CATALOG sur le END terminant le programme avec les labels locaux. Si c'est le dernier programme rentré faire: CAT 1 suivi immédiatement de R/S, puis avec SST avancer jusqu'au .END. REG final, revenir sur le END précédent avec BST puis passer en mode programme. Vous devez alors être à la fin de votre programme.

En effet même s'il n'y a pas de label global le END de fin généré lors du GTO .. est toujours visible dans le CATALOG.

fjhdavid
Sous apprenti
Messages : 6
Inscription : mer. 24 déc. 2008 13:35

Re: Retrouver un label local apres packing ?

Messagepar fjhdavid » mar. 18 nov. 2014 10:38

merci beaucoup, c'est délicat comme manip mais ça marche;

dorénavant, je ferai toujours un label global en début de programme!


Revenir vers « Programmation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 2 invités